Com2x3 bad performance

  • The websockets are not working which is why chat/troop movements are getting screwed up
    As you can see from the screenshot, The websockets protocol's frames have no reply from the server except polling queries. I would suggest to check the code which subscribes the player to the websocket. As you can see, there is clearly no reply from the server for that continuous messages from my browser. This is the reason why no data is being provided by the server via websockets. Why this happens only sometimes and not the other times is still a mystery to me.


    @Georgi


    The Bolton sends his regards :evil:

  • And once more there is the same problem as on every single speed server I played and I am really glad I did not start as king this time, because I would be pissed even more and way earlier. But its also not playable for a governor!!! Can't you prepare servers properly or optimize them? If you have a problem with that, make more speeds with less people. I think you are just waiting for people to stop playing so servers wouldn’t be so crowded and pressured. My patience is running out.


    I'm disconnected every 1-2 minutes
    F5 and Neverending Story

    Time is a Flat Circle

    Everything we have ever done or will do, we are going to do over and over and over again.

  • I second what Sca7ha said.


    The game is unplayable for few months now, happens on every single world I play. As a heavy gold user, I would really expect you to fix it because this doesnt happen anywhere else if you pay for the game, only here on TK. We also spend more money here than on other games.


    Please, stop talking about fixing it and really work hard on it. Com1x3 was laggy as well. We reported the issue several times and all we got was reassurance every now and then that the devs are working towards a solution. I know that is your job, Georgi, but nothing is happening, really. We played that server for three months and it was all the same till last few minutes when I was unable to properly lead our offenses to a WW, because we couldnt communicate via the game properly.


    It was the same on com2x3 even before that btw and Im not even talking about other slow servers, where people are experiencing same issues.


    Since yesterday, my chat wasnt even visible. I am glad we decided to play casualy this time...

  • My message system has stopped working. I can't communicate with my kingdom and that's annoying.

    I experience the same problem. It even happens that I want to write a message to someone, by clicking on the 'start chat' button on their profile which opens an igm box with no name in the header.

  • Hi all,


    Our developers have managed to identify a few sources of the problems and fixed them. They will deliver the hotfix within the next hour.
    It should make the experience better and reduce the problems you're experiencing, but they are continuing investigating other possible sources for these problems to make sure there are no more issues at all


    Regards,
    JJ

  • Hi again
    I understand your gaming experience is far from pleasant at the moment but please bear with us while we're working towards a solution, I'll get back to you as soon as I have updates


    Kind regards
    Georgi

    How about this.
    You get into the game.
    I reported it what three months ago. on com1x3
    You said your devs were working on it.
    But apparently same shitty issues are back, because you can't handle the playerbase

  • I make a list with problems:))
    - chat system down
    - building time (almost same like normal server)
    - sync server down
    - auction market price bug
    -and more

  • Hi again guys,
    Our devs did some improvements so it should be working normally/better now, could you please check again(please also clear your cache and cookies)?
    A hotfix will also be rolled out globally soon.


    Best regards
    Georgi

    Community Manager
    Travian Kingdoms International

  • Hi again guys,
    Our devs did some improvements so it should be working normally/better now, could you please check again(please also clear your cache and cookies)?
    A hotfix will also be rolled out globally soon.


    Best regards
    Georgi

    Not fixed.
    Still same stuff