Can't open "lobby.kingdoms.com"

  • Recent days I couldn't open "lobby.kingdoms.com/" to switch my avatar. (Just the lobby website, I can visit the village website if I was already logged in).

    I'm in China, Jiangsu, Nanjing. I've tried several devices and networks to be sure that it's not my problem. I tried :

    1. my laptop with China Telecom network

    2. my desktop computer with university's education network

    3. my phone with China Mobile LTE network

    When visiting lobby, first I can see , then

    And then come out with “ERR_TIME_OUT”.

    Ping result


    I can only use vpn to access the lobby website which isn't a convenient way.


    Hope you can solve the problem :D.

    Thx.

  • Hello


    I checked this with our tech support and sysadmins and according to them its the CHINANET problem. They might have blocked our websites as it happened in the past and hence we dont have any chinese servers now. Sadly we can't do anything in such cases but you can try to ask your provider for assistance.


    Kind regards
    Georgi

    Community Manager
    Travian Kingdoms International

  • Hello


    I checked this with our tech support and sysadmins and according to them its the CHINANET problem. They might have blocked our websites as it happened in the past and hence we dont have any chinese servers now. Sadly we can't do anything in such cases but you can try to ask your provider for assistance.


    Kind regards
    Georgi

    Thank you for helping. It seems a difficult problem because several networks act in the same way.

    I'm just confused that why blocking just ONE website while I can visit others such as village website and forum as I used to.

    Also PING result is normal.